Scripts ne marchent plus sur Firefox

Discussion dans 'Projets communautaires' démarrée par Hildoceras, 5 Mai 2019.

Partager cette page

  1. Hildoceras

    Hildoceras Maire

    Inscrit depuis le :
    16 Novembre 2010
    Messages :
    787
    "J'aime" reçus :
    70
    Il se peut que les scripts ne fonctionnent plus sur Firefox. Et quand vous allez charger Greasemonkey ou Tampermonkey, on vous répond qu'on ne peut pas se connecter pour charger le programme.
    C'est la faute de Mozilla, l'éditeur de Firefox ! En gros ils ont voulu que par sécurité tous les programmeurs utilisent leur application dédiée (une API) et ont bloqué de fait (en faisant expirer un certificat de sécurité) les autres (dont les "monkey" et aussi adblock et d'autres applications).

    Firefox a édité une réparation, un "fix".
    cf. https://venturebeat.com/2019/05/04/...ter-expired-certificate-disabled-all-add-ons/

    Pour les ceusses qui ne lisent pas l'anglais, il faut aller dans dans options>>vie privée et sécurité >>collecte des données par Firefox et utilisation. Là on coche Autoriser Firefox à lancer des études. C'est par ce biais que la réparation arrivera, au bout de 6 heures soi-disant, quelques minutes pour moi. J'ai du relancer les fenêtres de jeu, les scripts ne retrouvant pas les données sur le coup (plus d'amis, plus d'objets dans les listes :D )


    edit : on m'a signalé que ça avait marché pour un autre que moi et dans les mêmes conditions (quelques minutes et relance de la fenêtre)
     
    Dernière édition: 5 Mai 2019
  2. OTTAWA1

    OTTAWA1 Roi de la gâchette

    Inscrit depuis le :
    20 Mars 2015
    Messages :
    2.348
    "J'aime" reçus :
    231
    Yep j'ai entendu dire qu'il fallait prendre Opéra c'est tamper aussi comme FF
     
  3. Hildoceras

    Hildoceras Maire

    Inscrit depuis le :
    16 Novembre 2010
    Messages :
    787
    "J'aime" reçus :
    70
    c'est un problème purement lié à Firefox. Opera, Edge, Chrome ou Safari ne sont pas concernés.
     
  4. Richardson

    Richardson Shérif

    Inscrit depuis le :
    22 Septembre 2009
    Messages :
    413
    "J'aime" reçus :
    179
    D'accord, je me demandais pourquoi je n'avais pas subi ce bug contrairement à beaucoup d'autres.

    Mais ce genre de... bêtise, me donne envie de retourner sur Opera.
     
  5. Cathy08300

    Cathy08300 Roi de la gâchette

    Inscrit depuis le :
    17 Octobre 2013
    Messages :
    2.074
    "J'aime" reçus :
    130
    J'ai également ce gros souci depuis hier :mad: Mon pc est ancien donc je suis à la version 52 de Firefox . Pour moi impossible d'aller autoriser Firefox à lancer des études car je ne le trouve pas :eek:
    Si quelqu'un pouvait me dire comment on fait cela serait sympa car depuis hier je cherche et je n'arrive pas à trouver . Je suis allée dans les 3 petits traits en haut à droite il y a bien marqué vie privée et en dessous sécurité mais rien ne mentionne la collecte des données et autres .

    il faut aller dans dans options>>vie privée et sécurité >>collecte des données par Firefox et utilisation. Là on coche Autoriser Firefox à lancer des études.
     
  6. puma62

    puma62 Capitaine

    Inscrit depuis le :
    20 Février 2018
    Messages :
    204
    "J'aime" reçus :
    18
    bonjour

    j'ai eu le même problème , la solution résolu en 10mn , il fallait tout simplement dégager firefox ,le remettre et réinstaller les scripts

    pourquoi faire compliqué quand on peut faire simple !!
     
    Cathy08300 aime ce message.
  7. Hildoceras

    Hildoceras Maire

    Inscrit depuis le :
    16 Novembre 2010
    Messages :
    787
    "J'aime" reçus :
    70
    :confused: euh... oui... ça marche surement aussi
    clic options, clic vie privée, clic cocher la case
    ou alors
    clic démarrer, clic paramètres, clic applications, clic applications et fonctionnalités, clic Mozilla Firefox clic désinstaller, clic Google, taper firefox clic rechercher, clic télécharger, clic télécharger maintenant, clic exécuter...
    :D
    Remarque avec ça c'est propre. Mieux que ça y a juste le lance-flammes :D
     
    Cathy08300 et Richardson aiment cela.
  8. Cathy08300

    Cathy08300 Roi de la gâchette

    Inscrit depuis le :
    17 Octobre 2013
    Messages :
    2.074
    "J'aime" reçus :
    130
    Oui mais tu dois avoir la dernière version de Firefox donc avec la nouvelle versions tout rentre dans l'ordre . Moi je ne peux pas installer la dernière version car mon pc est sous Windows xp .
    Tu as quelle version ?

    Merci Otta :D
     
  9. Loup Anar

    Loup Anar Conseiller

    Inscrit depuis le :
    13 Mai 2015
    Messages :
    192
    "J'aime" reçus :
    23
    depuis deux jours, le cloth calc dysfonctionne ; impossible à gérer... la fenêtre ne s'ouvre pas et cherche sans cesse.

    la case "Autoriser Firefox à installer et à lancer des études" est pourtant bien cochée...

    des solutions ?
     
  10. bigdragonball

    bigdragonball Diplomate

    Inscrit depuis le :
    4 Octobre 2010
    Messages :
    1.452
    "J'aime" reçus :
    11
    Le problème est également présent sur Chrome depuis plusieurs jours, et nous ne sommes pas les seuls auquels cela arrive

    Il doit probablement venir de la part des développeurs (enfin, du script qui a cessé de fonctionner suite à un évènement dont nous ignorons la cause ...)

    J'ai tenté d'envoyer un message via "signaler un bug" il y a quelques jours mais hélas aucune réponse jusqu'à présent ...
     
    Cathy08300 aime ce message.
  11. Thathanka Iyothanka

    Thathanka Iyothanka Wikimédien(ne) Membre de l'équipe

    Inscrit depuis le :
    9 Avril 2012
    Messages :
    827
    "J'aime" reçus :
    96
    Le bug vient de tw db, apparemment des nouveaux items ajoutés récemment.
    Ça a été remonté aux admins, il faudra peut être patienter un peu si ça nécessite une intervention de Petee.
     
    Loup Anar aime ce message.
  12. tiki29

    tiki29 Citoyen

    Inscrit depuis le :
    13 Janvier 2011
    Messages :
    63
    "J'aime" reçus :
    0
    Bonjour, des nouvelles pour tw db? Ca ne fonctione toujours pas chez moi.
     
  13. dede57

    dede57 Blanc-bec

    Inscrit depuis le :
    11 Août 2010
    Messages :
    2
    "J'aime" reçus :
    0
    Toujours le meme bug que ce soit sur chrome ou firefox, c'est rageant
     
  14. Thathanka Iyothanka

    Thathanka Iyothanka Wikimédien(ne) Membre de l'équipe

    Inscrit depuis le :
    9 Avril 2012
    Messages :
    827
    "J'aime" reçus :
    96
    Pour ceux qui voudraient une solution temporaire en attendant un correctif de la part de tw db, vous pouvez le remplacer par celui-ci https://greasyfork.org/fr/scripts/387794
    En revanche, le calculateur ne prendra pas en compte les armes perlées, du patriote ou de l'armée américaine.
     
    Dernière édition: 23 Juillet 2019
    Cathy08300 aime ce message.
  15. tiki29

    tiki29 Citoyen

    Inscrit depuis le :
    13 Janvier 2011
    Messages :
    63
    "J'aime" reçus :
    0
    Merci, tu peux expliquer comment faire STP.
     
  16. Zaladin

    Zaladin Diplomate

    Inscrit depuis le :
    25 Octobre 2013
    Messages :
    1.610
    "J'aime" reçus :
    59
    Houla ! je peux avoir un diff plutôt ?

    EDIT : bon, je vais faire mon diff tranquille. Mais un peu compliqué avec du code linéralisé
     
  17. Thathanka Iyothanka

    Thathanka Iyothanka Wikimédien(ne) Membre de l'équipe

    Inscrit depuis le :
    9 Avril 2012
    Messages :
    827
    "J'aime" reçus :
    96
    J'ai modifié mon message, tu n'as plus qu'à cliquer sur le lien et installer le script normalement :)
     
    Dernière édition: 23 Juillet 2019
  18. tiki29

    tiki29 Citoyen

    Inscrit depuis le :
    13 Janvier 2011
    Messages :
    63
    "J'aime" reçus :
    0
    j'ai reinstallé, mais cela ne fonctionne pas.
     
  19. eve71

    eve71 Conseiller

    Inscrit depuis le :
    13 Octobre 2012
    Messages :
    111
    "J'aime" reçus :
    3
    salut
    j'avais le même problème que vous depuis plusieurs jours et ce matin tout semble rentrer dans l'ordre sans aucune manip de ma part, espérons que ça dure
     
  20. tiki29

    tiki29 Citoyen

    Inscrit depuis le :
    13 Janvier 2011
    Messages :
    63
    "J'aime" reçus :
    0
    Hello, tu as de la chance, chez moi toujours pas:(